首页 行情 入门 看盘 选股 买入 卖出 跟庄 短线 止损 解套 基本面 技术面 帮助

股票免费飞狐公式

子栏目: 免费通达信指 免费同花顺公 免费大智慧公 免费飞狐公式

花都股票学习网 > 指标公式 > 免费飞狐公式 > 飞狐轻松寻牛主图指标公式

飞狐轻松寻牛主图指标公式

来源:花都股票学习网 阅读: 日期:2020年10月22日 20:21:57

§9§ §9§ input:N(20,1,111),N1(8,1,111),N2(73,1,111);
DRAWBKBMP(CLOSE>0,'0-19.bmp');
M2:EMA(CLOSE,8),colorCC6600;
M3:EMA(M2,12),LINETHICK2,colorCC99FF;
M4:EMA(M2,45),colorFFFF00;
VAR1:=EMA(M3,45);
FILLRGN((M2 >= M3),M2,M3),colorCC99FF;
FILLRGN((M2 < M3),M2,M3),colorCC6600;
A1:=MA(CLOSE,13);
ZX:=REF(A1,13/2+1);
VAR1111:=FORCAST(CLOSE,5);
VAR1:=1;

HH:=HHV(HIGH,10);
LL:=LLV(LOW,10);
AA:=SMA(CLOSE,13,2);DRAWTEXT(ISLASTBAR=1 AND AA>REF(AA,1) AND REF(AA,1)<REF(AA,2) AND REF(AA,2)<REF(AA,3),HH,'激进买入'),COLORRED;
DRAWTEXT(ISLASTBAR=1 AND AA>REF(AA,1) AND REF(AA,1)>REF(AA,2),HH,'激进持股'),COLOR0066FF;
DRAWTEXT(ISLASTBAR=1 AND AA<REF(AA,1) AND REF(AA,1)>REF(AA,2),HH,'激进卖出'),COLORGREEN;
A1:=MA(CLOSE,13);ZX:=REF(A1,13/2+1);
DRAWTEXT(ISLASTBAR=1 AND CROSS(CLOSE,ZX),LL,'稳健买入'),COLORRED;
DRAWTEXT(ISLASTBAR=1 AND CLOSE>ZX AND REF(CLOSE,1)>REF(ZX,1),LL,'稳健持股'),COLOR0066FF;
DRAWTEXT(ISLASTBAR=1 AND CLOSE<ZX AND REF(CLOSE,1)>REF(ZX,1),LL,'稳健卖'),COLORGREEN;
VAR1111:=FORCAST(CLOSE,5);
VAR1:=1;平衡线:=(EMA(EMA(EMA(HIGH,3),3),1) * VAR1);
VAR2:=(平衡线 * 0.85);
临界线:WMA(CLOSE,10),LINETHICK2;
VAR1:=POW((CLOSE - 临界线),1);
VAR2:=MA(VAR1,3);
VAR3:=SQRT(VAR2);
支撑线:=(临界线 - (1.96 * VAR3));
PARTLINE((临界线 < REF(临界线,1)),临界线),LINETHICK2,colorFF00;
VAR1Z:=(((CLOSE - OPEN) / OPEN) * 100);
VAR2Z:=REF(CLOSE,1);
VAR3Z:=((SMA(MAX((CLOSE - VAR2Z),0),6,1) / SMA(ABS((CLOSE - VAR2Z)),6,1)) * 100);
VAR4Z:=(COUNT((VAR3Z < 20),20) >= 1);
DRAWTEXT(((VAR1Z > 9) AND VAR4Z),LOW,'★屠龙'),LINETHICK4,colorFFFF;
JJJ:=(((CLOSE + HIGH) + LOW) / 3);
AA:=EMA(JJJ,3);
BB:=REF(AA,1);
持股:DRAWICON((AA > BB),BB,12);
VAR3:=REF(CLOSE,1);
VAR4:=REF(CLOSE,2);
VAR5:=REF(CLOSE,3);
VAR6:=REF(CLOSE,9);
VAR7:=HHV(CLOSE,9);
VAR8:=LLV(CLOSE,9);
VARC:=(((VAR3 = VAR8) AND (CLOSE >= VAR4)) OR ((((VAR4 = VAR8) AND (VAR3 <= VAR5)) AND (VAR4 < VAR6)) AND (CLOSE >= VAR3)));
黄色买入:STICKLINE(VARC,(VAR3 * 0.94),(VAR4 * 0.94),25,16),colorFFFF;
VAR1:=((REF(HIGH,1) + REF(LOW,1)) / 2);
VAR2:=((REF(HIGH,1) + REF(LOW,1)) / 2);
VAR3:=(MA(CLOSE,N) + (2 * STD(CLOSE,N)));
DRAWICON(CROSS(VAR2,VAR3),(HIGH * 1.035),3);
DRAWTEXT(CROSS(VAR2,VAR3),(HIGH * 1.02),'卖出1'),colorFF00;
VAR4:=REF(CLOSE,1);
VAR5:=((SMA(MAX((CLOSE - VAR4),0),N1,1) / SMA(ABS((CLOSE - VAR4)),N1,1)) * 100);
VAR6:=CROSS(N2,VAR5);
VAR7:=FILTER(VAR6,4);
A7:=((((2 * CLOSE) + HIGH) + LOW) / 4);
VAR10:=LLV(LOW,34);
VAR11:=HHV(HIGH,34);
SK:=EMA((((A7 - VAR1) / (VAR2 - VAR1)) * 100),7);
SD:=EMA(((0.667 * REF(SK,1)) + (0.333 * SK)),5);
DRAWTEXT(IF((((((COUNT((CLOSE < REF(CLOSE,1)),8) / 8) > (6 / 10)) AND (VOL >= (1.5 * MA(VOL,5)))) AND COUNT((SK >= SD),3)) AND (REF(LOW,1) = LLV(LOW,120))),1,0),LOW,'●买进1'),color99FF;
DRAWTEXT(IF((((((((((COUNT((CLOSE < REF(CLOSE,1)),13) / 13) > (6 / 10)) AND COUNT((SK > SD),6)) AND (REF(LOW,5) = LLV(LOW,120))) AND REF((CLOSE >= OPEN),4)) AND REF((CLOSE > OPEN),3)) AND REF((CLOSE > OPEN),2)) AND REF((OPEN > CLOSE),1)) AND (OPEN > REF(CLOSE,1))),1,0),LOW,'●买进2'),colorFFFF;
VAR12:=(MA(CLOSE,80) - (MA(CLOSE,10) / 3));
DRAWTEXT(IF(((((CLOSE < VAR12) AND ((VOL / 240) > (MA(VOL,5) / 240))) AND (CLOSE > (REF(CLOSE,1) * 1.08))) AND (CLOSE < (MA(CLOSE,13) * 1.3))),1,0),LOW,'●抄底'),colorFFFF;
VAR11:=(((((2 * CLOSE) + OPEN) + HIGH) + LOW) / 5);
M8:=VOL;
主力:=(SUM((VAR11 * M8),3) / SUM(M8,3));
散户:=主力;
M1:=LLV(散户,5);
VAR11:=(((((2 * CLOSE) + OPEN) + HIGH) + LOW) / 5);
M8:=VOL;
M5:=(SUM((VAR11 * M8),1) / SUM(M8,1));
M13:=(SUM((VAR11 * M8),5) / SUM(M8,5));
M21:=(SUM((VAR11 * M8),13) / SUM(M8,13));
主力:=(SUM((VAR11 * M8),3) / SUM(M8,3));
Y:=(SUM((VAR11 * M8),21) / SUM(M8,21));
U1:=M5;
U3:=M13;
散户:=主力;
XX1:=M21;
C5:=((U3 > 散户) AND (散户 > XX1));
C8:=IF((C5 > 0),LLV(U3,5),HHV(散户,5));
C13:=IF((C5 > 0),LLV(散户,8),HHV(散户,5));
VAR1118:=IF((C5 > 0),LLV(XX1,13),HHV(散户,5));
M1:=LLV(散户,20);
DRAWTEXT((M1 = REF(M1,1)),M1,'┬'),LINETHICK5,colorCC33FF;
DRAWTEXT(((REF(M1,1) < REF(M1,2)) AND (M1 = REF(M1,1))),M1,'★'),colorFF;
STICKLINE((CLOSE < OPEN),HIGH,LOW,1,0),color8800;
STICKLINE((CLOSE < OPEN),HIGH,LOW,0,0),colorFF00;
STICKLINE((CLOSE < OPEN),CLOSE,OPEN,8,0),color8800;
STICKLINE((CLOSE < OPEN),CLOSE,OPEN,7,0),color9900;
STICKLINE((CLOSE < OPEN),CLOSE,OPEN,6,0),colorAA00;
STICKLINE((CLOSE < OPEN),CLOSE,OPEN,5,0),colorBB00;
STICKLINE((CLOSE < OPEN),CLOSE,OPEN,4,0),colorCC00;
STICKLINE((CLOSE < OPEN),CLOSE,OPEN,3,0),colorDD00;
STICKLINE((CLOSE < OPEN),CLOSE,OPEN,2,0),colorEE00;
STICKLINE((CLOSE < OPEN),CLOSE,OPEN,1,0),colorFF00;
STICKLINE((CLOSE >= OPEN),HIGH,LOW,1,0),colorFF;
STICKLINE((CLOSE >= OPEN),HIGH,LOW,0,0),colorEEFF;
STICKLINE((CLOSE >= OPEN),CLOSE,OPEN,8,0),colorFF;
STICKLINE((CLOSE >= OPEN),CLOSE,OPEN,7,0),color22FF;
STICKLINE((CLOSE >= OPEN),CLOSE,OPEN,6,0),color44FF;
STICKLINE((CLOSE >= OPEN),CLOSE,OPEN,5,0),color66FF;
STICKLINE((CLOSE >= OPEN),CLOSE,OPEN,4,0),color88FF;
STICKLINE((CLOSE >= OPEN),CLOSE,OPEN,3,0),colorAAFF;
STICKLINE((CLOSE >= OPEN),CLOSE,OPEN,2,0),colorCCFF;
STICKLINE((CLOSE >= OPEN),CLOSE,OPEN,1,0),colorEEFF;
VAR22:=((LLV(LOW,3) = LLV(LOW,3)) AND (CLOSE >= (OPEN * 1.04)));
VAR333:=(CLOSE > ((REF(HIGH,1) + REF(LOW,1)) / 2));
VAR44:=(VAR22 AND VAR333);
VAR55:=BARSLAST(VAR333);
VAR66:=BARSLAST(VAR44);
VAR77:=IF((VAR66 > 0),(((CLOSE - REF(CLOSE,1)) / REF(CLOSE,1)) * 100),0);
VAR88:=SUM(VAR77,1);
VAR93:=IF((VAR55 > 3),(0 - 2),0);
DRAWICON(((REF(VAR93,1) = (0 - 2)) AND (VAR93 = 0)),LOW,1),colorFF;
DRAWICON(((REF(VAR93,1) = (0 - 2)) AND (VAR93 = 0)),LOW,8),colorFF;
DRAWTEXTEX(SYSPARAM(3)=BARPOS,0,10,8,'【代码:'+STKLABEL+' 名称:'+STKNAME+'】'),Colorcyan;
DRAWTEXT((BARPOS = SYSPARAM(2)),HIGH,('所属板块:' + BLKNAME)+ ' ')ALIGN4,colorred;
BB:=BARPOS=SYSPARAM(1);
variable:wday[7]='星期六';
wday[1]:='星期日';
wday[2]:='星期一';
wday[3]:='星期二';
wday[4]:='星期三';
wday[5]:='星期四';
wday[6]:='星期五';
fy:=YEAR;
fm:=MONTH;
fd:=DAY;
wd:=WEEKDAY;
p:=SYSPARAM(1);
str1:='今天是:'+NUMTOSTR(fy[p],0)+'年'+NUMTOSTR(fm[p],0)+'月'
+NUMTOSTR(fd[p],0)+'日, '+wday[wd[p]+1];
EXPLAIN(BARPOS=p,str1),colorRED;
DRAWTEXT(BARPOS=p,HIGH*1.12,str1),ALIGN2,coloryellow,;
DRAWTEXT(SYSPARAM(2)=BARPOS,CLOSE,
'收益:'+ NUMTOSTR(FINANCE(33),2)+' '
+'净资:'+NUMTOSTR(FINANCE(34),2 )+' '
+'流通:'+ NUMTOSTR(FINANCE(7)/10000,2)+'亿'+' '
+'流通:'+NUMTOSTR(FINANCE(7)/FINANCE(1)*100 ,0)+' %'+' '
+'权益:'+NUMTOSTR(FINANCE(36),0 )+' %'+' '
+'主营:'+NUMTOSTR(FINANCE(53),0 )+' %'+' '
+'利润:'+NUMTOSTR(FINANCE(54),0 )+' %'+' '
+'主营:'+NUMTOSTR(FINANCE(20)/10000,1 )+'亿'+' '
),COLORccffcc,ALIGN4;

v1:EMA(CLOSE,5);
v2:EMA(EMA(CLOSE,90)*1.01,10),;
DRAWTEXT(CROSS(v1,v2),v1+0.05,'追牛'),color00ff00,LINETHICK2;
VAR1:=LLV(LOW,21);
VAR2:=HHV(HIGH,21);
AK1:=EMA((((CLOSE - VAR1) / (VAR2 - VAR1)) * 100),5);
AK:=EMA((((CLOSE - VAR1) / (VAR2 - VAR1)) * 50),13);
AB:=CROSS(AK1,AK);
DRAWICON(CROSS(v1,v2),v2,1);
DRAWTEXT((AB = 1),(LOW * 0.99),'○牛窝进呀'),colorYELLOW;
M5:MA(CLOSE,5),LINETHICK1,colorYELLOW;
M13:MA(CLOSE,13),LINETHICK2,color0099ff;

A:MA(CLOSE,3),ColorFF00FF,LINETHICK0;
A1:=(CLOSE+HIGH+LOW)/(3);
B:=EMA(A1,10);
B2:=REF(B,1);
MA20:=EMA(CLOSE,20);
DRAWTEXT((B>B2),ma20,'*'),COLORMAGENTA;
DRAWTEXT((B<B2),ma20,'*'),Coloryellow;

{以下设置逃顶指标}
varC:=SMA(MAX(CLOSE-REF(CLOSE,1),0),6,1)/SMA(ABS(CLOSE-REF(CLOSE,1)),6,1)*100;
DRAWICON(CROSS(82,varC),HIGH,2);
var6:=REF(CLOSE,1);
var7:=SMA(MAX(CLOSE-var6,0),6,1)/SMA(ABS(CLOSE-var6),6,1)*100;
DRAWTEXT(CROSS(84,var7),HIGH*1.01,'▲逃顶'),COLORGREEN ;
{追涨}
Var32:=CLOSE/REF(CLOSE, 1)>=1.062 AND HIGH/CLOSE<1.005 AND MA(CLOSE, 90)/CLOSE>=1.150;
Var33:=Var32 AND COUNT(Var32, 20)=1 ;
Var34:=(INDEXC-REF(INDEXC, 1))/REF(INDEXC, 1);
Var35:=(CLOSE-REF(CLOSE, 1))/REF(CLOSE, 1);
Var36:=IF(Var34>0.010, 0.900, 1) AND IF(Var34>(-0.025), 1, 1.200);
Var37:=Var36*(Var35-Var34)*100;
Var38:=SUM(Var37, 10);
Var39:=SMA(Var38, 40, 1);
Var310:=Var38>20;
Var311:=CROSS(CLOSE, MA(CLOSE*1.055, 3)) AND CLOSE>OPEN*1.060 AND VOL>=REF(VOL, 1)*1.5 AND CLOSE>=MA(CLOSE, 10);
Var312:=Var310 AND Var311 ;
Var313:=(-100)*(HHV(HIGH, 3)-CLOSE)/(HHV(HIGH, 3)-LLV(LOW, 3));
Var314:= CROSS(Var313, (-87)) AND OPEN=1.090*REF(CLOSE, 1) AND INDEXC>0.980*REF(INDEXC, 1) AND CLOSE<=1.470*LLV(CLOSE, 58);
Var315:=EMA(CLOSE, 12)-EMA(CLOSE, 26);
Var316:=EMA(Var315, 9);
Var317:=2*(Var315-Var316);
Var318:=(CLOSE-LLV(LOW, 9))/(HHV(HIGH, 9)-LLV(LOW, 9))*100;
Var319:=SMA(Var318, 3, 1);
Var320:=SMA(Var319, 3, 1);
Var321:=EMA(IF(Var316>REF(Var316, 1), 1, (-1)), 14)*14;
Var322:=EMA(IF(Var320>REF(Var320, 1), 1, (-1)), 14)*14*2;
Var323:=(MA(CLOSE, 5)/MA(CLOSE, 70)-1)*100;
Var324:=(Var323+Var322+Var321)/3;
Var325:=MA(CLOSE, 80)-MA(CLOSE, 10)/3;
Var326:=IF(CLOSE and MA(VOL, 5)/240 AND CLOSE>REF(CLOSE, 1)*1.0 AND CLOSE,88,0);{Var38>Var39;}
Var327:=IF(CLOSE/REF(CLOSE, 1)>1.050 AND VOL/CAPITAL*100<10 AND CLOSE<17 AND HIGH/CLOSE<1.010 AND Var326>0, 91, 0);
Var328:=IF(Var324>REF(Var324, 1) AND REF(Var324, 1)<REF(Var324, 2) AND (Var33 OR Var312 OR Var314) OR Var326>0 OR Var327>0, 85, 0);
Var329:=IF(Var327>0 ,95,0), STICK,LINETHICK2;
Var330:=IF(Var326>0 or var327>0,91,0), STICK,LINETHICK2;
Var331:=IF(Var328>0 or var327>0 or var326>0,88,0), STICK,LINETHICK2;
Var332:=100*(CLOSE-LLV(LOW,42))/(HHV(HIGH,42)-LLV(LOW,42)),LINETHICK1,colorgreen;
Var333:=COUNT(MA(CLOSE,3)>REF(MA(CLOSE,3),1),1)=1;
Var334:=(Var332<93 AND Var333 and MAX(MAX(Var329, Var330), Var331))*100;
STICKLINE(Var327>90,LOW*0.99,LOW*0.95,2,0),COLORYELLOW;
DRAWTEXT(Var327>90,LOW*0.95,'追涨'),COLORYELLOW;
DRAWICON(Var310>0 AND Var327=0,HIGH*1.01,5);
VARCQ:=REF(CLOSE,1)=LLV(CLOSE,4) AND CLOSE>=REF(CLOSE,2) OR REF(CLOSE,2)=LLV(CLOSE,4) AND REF(CLOSE,1)<=REF(CLOSE,3) AND REF(CLOSE,2)<REF(CLOSE,4) AND CLOSE>=REF(CLOSE,1);
绿买:varcQ,color00ff00,LINETHICK0;STICKLINE(VARCQ,OPEN, (OPEN+CLOSE)/2,8,0),COLOR004400;

{立体柱子:绿色}STICKLINE(VARCQ,OPEN,(OPEN+CLOSE)/2,8,0),COLOR004400;
STICKLINE(VARCQ,OPEN,(OPEN+CLOSE)/2,6,0),COLOR005500;
STICKLINE(VARCQ,OPEN,(OPEN+CLOSE)/2,5,0),COLOR007700;
STICKLINE(VARCQ,OPEN,(OPEN+CLOSE)/2,4,0),COLOR009900;
STICKLINE(VARCQ,OPEN,(OPEN+CLOSE)/2,3,0),COLOR00BB00;
STICKLINE(VARCQ,OPEN,(OPEN+CLOSE)/2,2,0),COLOR00DD00;
STICKLINE(VARCQ,OPEN,(OPEN+CLOSE)/2,1,0),COLOR00FF00;
STICKLINE(VARCQ,OPEN,(OPEN+CLOSE)/2,8,0),COLOR004400;
STICKLINE(VARCQ,OPEN,(OPEN+CLOSE)/2,6,0),COLOR005500;
STICKLINE(VARCQ,OPEN,(OPEN+CLOSE)/2,5,0),COLOR007700;
STICKLINE(VARCQ,OPEN,(OPEN+CLOSE)/2,4,0),COLOR009900;
STICKLINE(VARCQ,OPEN,(OPEN+CLOSE)/2,3,0),COLOR00BB00;
STICKLINE(VARCQ,OPEN,(OPEN+CLOSE)/2,2,0),COLOR00DD00;
STICKLINE(VARCQ,OPEN,(OPEN+CLOSE)/2,1,0),COLOR00FF00;

STICKLINE(CLOSE>OPEN,CLOSE,OPEN,8,0) ,COLOR000033;
STICKLINE(CLOSE>OPEN,CLOSE,OPEN,6,0) ,COLOR000066;
STICKLINE(CLOSE>OPEN,CLOSE,OPEN,4,0) ,COLOR000099;
STICKLINE(CLOSE>OPEN,CLOSE,OPEN,3,0) ,COLOR0000BB;
STICKLINE(CLOSE>OPEN,CLOSE,OPEN,1,0) ,COLOR0000DD;
VAR9Q:=CLOSE= HHV(CLOSE,4)AND (REF(CLOSE,1)>=REF(CLOSE,2) OR REF(CLOSE,1)>=REF (CLOSE,3)) OR REF(CLOSE,1)=HHV(CLOSE,4) AND CLOSE>=REF(CLOSE,2) OR REF(CLOSE,2) =HHV(CLOSE,4) AND REF(CLOSE,3)=LLV(CLOSE,4) AND CLOSE>=REF(CLOSE,1) OR REF(CLOSE,3) =HHV(CLOSE,4) AND CLOSE>=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
红持:var9Q,color0000ff,LINETHICK0;

  以上是本站关于“飞狐轻松寻牛主图指标公式”的详细内容介绍,更多精彩请收藏本站。

标签:
编辑:大牛骑士

热点排行榜