首页 行情 入门 看盘 选股 买入 卖出 跟庄 短线 止损 解套 基本面 技术面 帮助

股票免费大智慧公式

子栏目: 免费通达信指标 免费同花顺公式 免费大智慧公式 免费飞狐公式

花都股票学习网 > 指标公式 > 免费大智慧公式 > 几个常用指标(大智慧)

几个常用指标(大智慧)

来源:花都股票学习网 阅读: 日期:2020年10月31日 19:16:08

{K线指标:K-S时价}

MA1:MA(CLOSE,2),Color003C7D;
MA2:MA(CLOSE,4),ColorFF00FF;
MA3:MA(CLOSE,7),Color009D7D;
MA4:MA(CLOSE,28),circledot,Colorwhite;
MA9:MA(CLOSE,49),crossdot,Color00FFFF;
MA6:MA(CLOSE,84),Color00FF00;
MA7:MA(CLOSE,168),Color00BCFF;


MA5:=MA(CLOSE,5);
MA10:=MA(CLOSE,10);
MA30:=MA(CLOSE,30);
MA60:=MA(CLOSE,60);
MA65:=MA(CLOSE,65);
MA250:=MA(CLOSE,250);
均线流:=(((((MA5 > MA65) AND (MA10 > MA65)) AND (MA30 > MA65)) AND (MA5 < MA30)) * 0.3);
PL1:=(((CLOSE - MA60) / MA60) < 0.1);
PL2:=(((CLOSE - MA250) / MA250) < 0.3);
偏离率:=(((PL1 = 1) AND (PL2 = 1)) * 0.2);
DIFF:=EMA(CLOSE,12) - EMA(CLOSE,26);
DEA :=EMA(DIFF,9);
MACD超跌:=(COUNT((DIFF < DEA),10) = 10);
MACD:=(MACD超跌 * "MACD.MACD"(26,12,9))*(-1);
目标:=if(均线流=0.3 AND macd and 偏离率=0.2 ,0.8,0);
DRAWTEXT(目标 ,l,'▲目'),color008fff;
MBSJ:=BARSLAST((目标 = 0.8));
放量上涨:=(((VOL / REF(VOL,1)) >= 1.1) AND ((CLOSE / REF(CLOSE,1)) >= 1.01));
SZSJ:=BARSLAST((放量上涨 = 1));
MACD金叉:=CROSS(DIFF,DEA);
JCSJ:=BARSLAST((MACD金叉 = 1));
关注:=((MACD金叉 AND (REF(MACD,1) < 0)) * -0.1);
DRAWTEXT(关注,l,'◆注'),color00ff00;
启动:=((((MBSJ <= 20) AND (SZSJ <= 1)) AND (JCSJ <= 1)) * 1);
DRAWTEXT(启动,l,'●启'),coloryellow;
突破:=((((偏离率 = 0) AND (REF(偏离率,1) = 0.2)) AND (REF((COUNT((偏离率 = 0.2),10) = 10),1) = 1)) * -0.1);
DRAWTEXT(突破,l,'★突'),colorRED;


买入:=ZIG(3,10)>REF(ZIG(3,10),1) AND REF(ZIG(3,10),1)<REF(ZIG(3,10),2);
卖出:=ZIG(3,10)<REF(ZIG(3,10),1) AND REF(ZIG(3,10),1)>REF(ZIG(3,10),2);

DRAWTEXT(ZIG(3,10)<REF(ZIG(3,10),1) AND REF(ZIG(3,10),1)>REF(ZIG(3,10),2),MA1,'★顶'),COLOrgray;
DRAWTEXT(ZIG(3,10)>REF(ZIG(3,10),1) AND REF(ZIG(3,10),1)<REF(ZIG(3,10),2),MA1,'★底'),COLORred;

顶换:sum(v,BARSLAST(卖出))/capital,colorred,linethick0;
底换:sum(v,BARSLAST(买入))/capital,colorred,linethick0;

DRAWTEXT(cross(顶换,0.5) and 顶换<2,MA1-0.4,'金买50'),COLORred;
DRAWTEXT(cross(底换,1.1) and 底换<2,MA1+0.4,'金卖110'),COLORwhite;


V2:=EMA(V1,300);
V3:=(CLOSE-LLV(LOW,8))/(HHV(HIGH,8)-LLV(LOW,8))*100;
V4:=SMA(V3,2,1);
V5:=SMA(V4,2,1);
V6:=CLOSE/REF(CLOSE,3)>=1.1;
V7:=BACKSET(V6,3);
买入:=if((V7 AND COUNT(V7,3)=1),30,0);


{z-主MM}

DRAWTEXTREL(10,5,'三五正面:'+BKNAME),COLORwhite;

VAR1:=VOL/((HIGH-LOW)*2-ABS(CLOSE-OPEN));
成交:=VOL;
主动买:=IF(CLOSE>OPEN,VAR1*(HIGH-LOW),IF(CLOSE<OPEN,VAR1*((HIGH- OPEN)+(CLOSE-LOW)),VOL/2));
主动卖:=IF(CLOSE>OPEN,0-VAR1*((HIGH-CLOSE)+(OPEN-LOW)),IF(CLOSE< OPEN,0-VAR1*(HIGH-LOW),0-VOL/2));

一日买:=SUM(主动买,1);
一日卖:=SUM(主动卖,1);

五日买:=SUM(主动买,5);
五日卖:=SUM(主动卖,5);
十日买:=SUM(主动买,10);
十日卖:=SUM(主动卖,10);
二十日买:=SUM(主动买,20);
二十日卖:=SUM(主动卖,20);


STICKLINE(VOL>0,VOL,0,4,1),colorwhite;
STICKLINE(主动买>0,0,主动买,4,0),colorred;
STICKLINE(主动卖<0,0,主动卖,4,0),color00ff00;

壹:(一日买+一日卖),Color00008C;

伍:(五日买+五日卖),coloryellow,LINETHICK2;
拾:(十日买+十日卖),colorMAGENTA;
贰拾:(二十日买+二十日卖),ColorFAFF00;


流通:CAPITAL/1000000,COLORgray;
百八:((流通*0.8)*100000),dotline,Color76357B,linethick0;
负百八:-((流通*0.8)*100000),dotline,Color76357B,linethick0;

DRAWTEXT(cross(伍,((流通*1.0)*100000)),百八,'★10'),Colorblue;
DRAWTEXT(cross(拾,((流通*1.0)*100000)),拾,'★10'),Color007800;
DRAWTEXT(cross(拾,贰拾),主动卖,'●翻多'),ColorFF5EFF;
DRAWTEXT(cross(伍,拾),主动卖,'●多'),ColorRED;

换手:=vol/capital*100;
壹流:(壹/capital)*100,linethick0;
拾流:(拾/capital)*100,linethick0;
贰拾流:(贰拾/capital)*100,linethick0;


{D-顶底B}

S1:80,COLOR996699,PRECIS0;
B1:20,COLORGREEN,PRECIS0;
A:=MA(-100*(HHV(HIGH,34)-CLOSE)/(HHV(HIGH,34)-LLV(LOW,34)),19);
B:=-100*(HHV(HIGH,14)-CLOSE)/(HHV(HIGH,14)-LLV(LOW,14));
D:=EMA(-100*(HHV(HIGH,34)-CLOSE)/(HHV(HIGH,34)-LLV(LOW,34)),4);
长线:A+100,ColorFF00FF,LINETHICK2;
短线:B+100,coloryellow,linethick2;
中线:D+100,ColorFFFF00,LINETHICK2;
中长差:(中线-长线),linethick0;


买入:=ZIG(3,10)>REF(ZIG(3,10),1) AND REF(ZIG(3,10),1)<REF(ZIG(3,10),2);
卖出:=ZIG(3,10)<REF(ZIG(3,10),1) AND REF(ZIG(3,10),1)>REF(ZIG(3,10),2);

{DRAWTEXT(v>MA(VOL,M3)*3.5,MA4,'★'),COLORred;}
DRAWTEXT(ZIG(3,10)<REF(ZIG(3,10),1) AND REF(ZIG(3,10),1)>REF(ZIG(3,10),2),80,'★顶'),COLORgreen;
DRAWTEXT(ZIG(3,10)>REF(ZIG(3,10),1) AND REF(ZIG(3,10),1)<REF(ZIG(3,10),2),20,'★底'),COLORred;

顶换:sum(v,BARSLAST(卖出))/capital,colorred,linethick0;
底换:sum(v,BARSLAST(买入))/capital,colorred,linethick0;

{DRAWTEXT(cross(顶换,0.5),MA1,'▲金买50'),COLORred;}
{DRAWTEXT(cross(底换,1.1),MA1,'▲金卖110'),COLORgreen;}
DRAWTEXT(cross(顶换,0.5) and 顶换<2,短线,'金买50'),COLORred;
DRAWTEXT(cross(底换,1.1) and 底换<2,短线,'金卖110'),COLORgreen;


见顶:(REF(中线,1)>85 AND REF(短线,1)>85 AND REF(长线,1)>65) AND CROSS(长线,短线),PRECIS0;
顶部区:(中线<REF(中线,1) AND REF(中线,1)>80) AND (REF(短线,1)>95 OR REF(短线,2)>95 ) AND 长线>60 AND 短线<83.5 AND 短线<中线 AND 短线<长线+4,PRECIS0;
顶部:=FILTER(顶部区,4);
底部区:(长线<12 AND 中线<8 AND (短线<7.2 OR REF(短线,1)<5) AND (中线>REF(中线,1) OR 短线>REF(短线,1))) OR (长线<8 AND 中线<7 AND 短线<15 AND 短线>REF(短线,1)) OR (长线<10 AND 中线<7 AND 短线<1),PRECIS0;
STICKLINE(顶部,98,103,20,1),COLORRED;
STICKLINE(底部区,-4,0,22,0),COLORGREEN;
STICKLINE(底部区,40,44,22,0),COLORGREEN;


低位金叉:长线<15 AND REF(长线,1)<15 AND 中线<18 AND 短线>REF(短线,1) AND CROSS(短线,长线) AND 短线>中线 AND (REF(短线,1)<5 OR REF(短线,2)<5) AND (中线>=长线 OR REF(短线,1)<1),PRECIS0;

PARTLINE(中线,中线>REF(中线,1),RGB(255,0,0)),LINETHICK2;
PARTLINE(长线,长线<=REF(长线,1),RGB(0,125,0)),LINETHICK2;

STICKLINE(低位金叉,0,4,11,0 ),COLORRED;
S0:10,COLORCC6633,LINETHICK2,PRECIS0;
B0:90,COLOR9966BB,LINETHICK2,PRECIS0;


{MACD-背变}

{设置缺省值:short:9,M:12,long:26}

DRAWTEXTREL(10,5,'正面负面:'+BKNAME),COLORwhite;

DIFF : EMA(CLOSE,SHORT) - EMA(CLOSE,LONG),COLORgreen;
DEA : EMA(DIFF,M),COLORyellow;
MACD : 2*(DIFF-DEA), COLORSTICK,COLOR5454FF;
DD:=C=HHV(C,180);
EE:=DEA< REF(DEA,1) AND REF(DEA< REF(DEA,1),1)=1;
CC:=C> REF(C,1) AND REF(C> REF(C,1),1)=1;
上升背离:(CC AND EE)*DEA,COLOR00FFFF;
顶背离:(DD AND EE AND DEA< HHV(DEA,180))*DEA,STICK,LINETHICK3,COLORGREEN;
FF:=C=LLV(C,180);
GG:= DEA> REF(DEA,1) AND REF(DEA> REF(DEA,1),1)=1;
LL:=C< REF(C,1) AND REF(C< REF(C,1),1)=1;
下降背离:(LL AND GG)*DEA,COLORMAGENTA;
底背离:(FF AND GG AND DEA> LLV(DEA,180))*DEA,STICK,LINETHICK3,COLORRED;
MM:=IF(MACD< 0,MACD,0);
JJ:=MM> REF(MM,1);
ZZ:=REF(JJ,1)=1;
介入区:(JJ AND ZZ)*DEA,POINTDOT,COLORRED;
STICKLINE(介入区=DEA,DEA,DIFF,3,0),COLORRED;
DRAWTEXT(CROSS(DIFF,DEA ),0,'金叉'),ColorFFFFFF;
DRAWTEXT(CROSS(DEA,DIFF ),0,'死叉'),COLORGREEN;

PARTLINE(DIFF,DIFF>(REF(DIFF,1)+0.008),RGB(255,0,0)){,COLORMAGENTA},LINETHICK2;
PARTLINE(DEA,DIFF<=(REF(DIFF,1)+0.008){长期线<=REF(长期线,1)},RGB(50,100,100)){,COLORFFFF00,LINETHICK2};


FH1:=REF(MACD,1)<REF(MACD,2) AND REF(MACD,2)<REF(MACD,3) AND REF(MACD,3)<REF(MACD,4);
FH2:=MACD>=0 AND COUNT(MACD>REF(MACD,1),1)=1;
FH3:=FH1 AND FH2 AND EMA(C,13)>REF(EMA(C,13),1);
FH4:=FH1 AND FH2 AND ABS((DIFF-DEA)/C)<0.018;
FH5:=FH1 AND FH2 AND MACD<0.10;

DRAWTEXT(FH3 OR FH4 OR FH5,DIFF,'★'),COLORred;

  以上是本站关于“几个常用指标(大智慧)”的详细内容介绍,更多精彩请收藏本站。

标签:
编辑:骑牛大力士

热点排行榜